FrSky Taranis, migrer en 2.1

29
9892

Taranis - TelemetryOn ne présente plus la radio Taranis de FrSky, 1ère du nom ou en version “plus”, que l’on retrouve régulièrement sur les terrains d’aéromodélisme. Mais savez-vous quelle version de firmware vous utilisez dessus : 2.0.9 ? 2.0.18 ? 2.0.19 ? 2.1.7 ? version EU ? non EU ? LBT ? non LBT ? Aucune idée ? OpenTX a sorti il y a quelques temps maintenant une nouvelle version “majeure” de son firmware destinée entre autre à la Taranis de FrSky (ce firmware tourne également sur les 9xr de Turnigy par exemple). On parle de version “majeure” car une grande partie du code a été réécrite, de nouvelles fonctionnalités sont apparues, et dans certains cas, il a fallu faire l’impasse sur la rétrocompatibilité.

Avant d’utiliser cette nouvelle version 2.1, il faudra prendre un certains nombre de précautions. En effet, il ne s’agit pas d’une simple mise à jour mais bien d’une migration. Vos modèles existants seront donc convertis, il vous faudra également, dans certains cas, reprendre la configuration du failsafe et de la télémétrie, et une nouvelle banque de sons devra être utilisée, ainsi que le “Wizard” de création d’un modèle dont le code a évolué. Si les premières versions 2.1 étaient destinées aux plus courageux, depuis la version 2.1.7, le code est maintenant stabilisé et ce firmware peut être utilisé par tout à chacun sur sa Taranis.

Comme toujours, il n’y a rien de compliqué dans cette migration, il faut cependant suivre les étapes une à une, dans un certain ordre. C’est ce que nous allons voir dans ce tutoriel.

Support des versions 2.0…

Avant de voir plus en détails les nouveautés de cette version 2.1, il faut garder à l’esprit que la première raison pour migrer c’est l’arrêt programmé des mises à jour des versions 2.0. La version 2.0.19 est prévue pour être la dernière de cette branche, sauf “gros” bug détecté. Donc si vous voulez profiter des corrections et améliorations, des nouveautés – nouvelles fonctionnalités, support de nouveaux protocoles, etc… – il faudra impérativement passer par les versions 2.1.

Les nouveautés de cette version 2.1…

Les nouveautés de cette branche 2.1 sont aussi bien à chercher du côté des fonctionnalités que du côté de la représentation graphiques des informations à afficher. La gestion du Failsafe a été améliorée et la partie télémétrie a été entièrement revue. Parmi les nouvelles fonctionnalités, on peut citer les fonctions globales ou la possibilité de flasher le module interne de la Taranis aussi bien que des récepteurs ou modules externes S.PORT (par exemple les récepteurs X4R ou X8R) via les pins du module arrière de la radio.

Voici une liste des nouveautés jusqu’en version 2.1.7 :

  • Meilleure représentation graphique des TRIM.
  • Taranis - 2.1Nouveau système de Télémétrie.
  • Ajout du support de la Taranis X9E.
  • Ajout du support du Bluetooth (sur la Taranis X9E).
  • Ajout d’un troisième Timer (Timer3).
  • Ajout de nouveaux modes d’écolage et de l’écolage sans fil.
  • Ajout des fonctions globales.
  • Ajout de la fonction spéciale : Capture d’écran.
  • Ajout de la possibilité de flasher le firmware du module interne ainsi que des modules externes S.PORT.
  • Ajout de menus d’accès rapides aux différentes sources et inter (par catégorie).
  • Amélioration de la gestion du Failsafe.
  • Possibilité de faire une remise à zéro complète de la radio à partir de la page “Version” des menus.
  • Visualisation de la sortie d’une voie dans l’onglet MIXER.
  • Possibilité de nommer les inter (interrupteurs) physiques, les potars (potentiomètres) et les sliders.
  • Possibilité de lire le nom du modèle, à partir d’un fichier .wav, lorsqu’il est sélectionné.
  • Ajout du support du protocole “Crossfire” de TBS via le pin S.PORT du module arrière.

Avant de migrer…

Lors de cette migration vers la version 2.1.7 (la dernière en date au moment d’écrire ce tutoriel), sachez que les modèles présents sur la radio seront convertis en format 2.1, vous ne pourrez donc pas revenir en arrière après la migration, à moins d’avoir sauvegardé au préalable vos modèles.

La partie télémétrie ayant été réécrite, lors de la migration de vos modèles, vous allez perdre toute vos personnalisations liées à la télémétrie, il faudra les refaire par la suite.

Enfin, la banque de sons que vous utilisiez en version 2.0 n’est plus compatible avec la version 2.1, il faudra donc en copier une nouvelle sur la carte SD de votre radio. Personnellement, j’ai été déçu par la voix de synthèse française choisie pour faire la banque de sons française 2.1, j’ai donc recréé une banque de sons à partir de la voie “Julie” (la même que celle utilisée par défaut dans les versions 2.0). Cette banque de sons est téléchargeable dans ce tutoriel.

[INFO] Les sons (.wav) que vous auriez pu ajouter vous-même en version 2.0 restent compatibles avec la version 2.1, ce sont essentiellement les sons dits “systèmes” (ceux qui vous donne le temps restant d’un compte à rebours par ex.) qui ont changé dans cette version.

Les différentes étapes…

Taranis - Version
Taranis – OpenTX v2.1.7

Avant de rentrer dans le vif du sujet, je vous propose de lister les étapes de cette migration, qui peut se décomposer ainsi (en cliquant sur un titre, vous pourrez vous rendre directement au paragraphe correspondant) :

[ASTUCE] Pour ceux qui ne souhaiteraient pas procéder à une sauvegarde préalable de leurs modèles en 2.0 – même si c’est recommandé -, et passer directement à la partie migration vers la version 2.1, vous pouvez ne pas tenir compte des étapes indiquées en ROUGE dans le sommaire.

>>> LA SUITE EN PAGE #2 <<<

29 COMMENTAIRES

  1. Ouaf ! Bravo pour ce roman et bon courage à ceux qui s’y lancent 🙂
    On souhaiterai quelquefois que les notices constructeurs soient aussi explicites ; beau travail 🙂

  2. Concrètement j’ai quoi à y gagner en passant de la 2.0.17 actuelle (avec mes script et mes configs qui fonctionnent bien), à la dernière ?

    J’ai pas envi de perdre tout mes réglages juste pour dire que j’ai la dernière version. Enfin faudra peut être y passer un jour mais je ne suis pas pressé.

  3. Je dis souvent :
    Quand ça marche bien faut rien toucher.
    Mais bravo pour ce tuto une nouvelle fois très complet, détaillé et clair.

    Nouveau chez frsky, j’attends justement une 9XE, il tombe carrément à pic.

  4. mille merci pour ce super tuto ! c’est vraiment génial Fred, j’adore vraiment venir sur helicomicro le soir en rentrant du boulot, y’a toujours le top de l’actu fpv racing. c’est trop bon ça. merci vraiment

  5. Merci pour cette information et pour le travail de synthèse !
    Ça va en aider plus d’un pour faire leur choix de migration ou non, moi y compris !!!

  6. Je le ferais surement pas, parce que la Taranis, pour l’instant me suffit amplement dans sa version actuelle pour les 2% que j’en utilise, mais merci à Fred et TiTidom pour ce travail de fourmi, extrêmement détaillé, et tellement altruiste !

    Un grand bravo et merci !

  7. super tuto, en revanche on est d’accord que cela n’intervient pas sur le fait que le module soit EU ou NON EU ?

  8. @Quentin01301 : on est d’accord oui 🙂 (et en 2.1, tu peux maintenant flasher ce module en EU ou non EU suivant le besoin, directement à partir de la radio, ce qui est plus simple qu’auparavant où il fallait plusieurs câbles et le logiciel SPORT updater sur ton ordinateur).

  9. Fred et Olivier,
    merci à vous deux, j’attendais avec impatience cet article !!! j’avais réussi à la faire mais partiellement (me manquait des infos pour l’arborescence de la SD).
    Je rajouterai que pour la découverte des capteurs, dans des cas bien précis comme le mien (Naze REV5, Télémetrie Fr-Sky), il faut armer les moteurs (sans hélice hein), pour voir apparaître l’ensemble des capteurs, surtout ceux correspondants à la tension de la LiPo).
    Encore merci, heureusement que vous êtes là !

  10. Merci beaucoup pour ce super tuto ! Je découvre à peine ma Taranis et j’ai appris plein de choses (y compris comment vérifier quelle version est installée, en la démarrant en bootloader).

    Olivier, tes tutos sur les softs sont top ! Bientôt Betaflight 2.5 😉

  11. Hello Fred,
    Je pense que mon XSR est en EU LBT, comme indiqué sur la boite. ( par contre je dois bien télécharger les firmware pour mes D4r2, pour les rendre compatibles avec mon firmware taranis en 2.1.6 , que je viens de checker, ca j’ai compris )

    Sur ma radio je ne vois pas le mode “EU LBT” juste “D16” et “LR12” : est-ce ok ?
    > Je tente de binder en D16 / ch 1-16 mon XSR et rien…( il y a-t-il une procédure différente pour le XSR ou est ce la même que pour le D4R2 ?
    > Ou
    > Dois-je encore faire une autre chose sur ma radio pour le voir apparaitre ce fameux Mode ? je pense que Oui car
    tu évoques “Radio” et “module” …? n’ai je pas flasher uniquement que la radio et pas encore “le module”, ce qui expliquerai la non présence du mode EU LBT ?
    si c’est le cas il y a t il encore d’autres choses à flasher ( en dehors de mes D4R2 …) après la radio et le module ?

    > Merci du support très précieux

  12. mais je n’ai pas de module externe! c’est l’atout du XSR ! donc mon flash de radio est ok mais mon Binding marche pas …

  13. @Julien : Je te confirme que les XSR achetés en France, sont en LBT (étiquette collée dessus), donc qu’il faut que le module (interne) de ta radio,soit lui aussi à la norme LBT (ou changer le firmware du récepteur en nonLBT, mais celui-ci n’est pas encore dispo pour le XSR…).

    Je te confirme également que si tu as flashé ta radio en suivant ce tuto, tu as flashé le firmware de la radio, mais PAS celui de ton module interne. Par contre, maintenant que tu es en 2.1, tu peux flasher ce module interne directement à partir des menus de la radio (le firmware pour ton module interne Taranis peut être téléchargé sur leur site : http://www.frsky-rc.com/download/view.php?sort=&down=232&file=Firmware-XJT )

    Ensuite, avec les séries X de FrSky (dont le XSR), c’est bien en mode D16 qu’il faut binder (le D16_LBT ou D16_nonLBT étant automatique en fonction du firmware que tu as mis dans le module)

  14. @Olivier: Fabuleux tuto pour quelqu’un qui attends sa Taranis, au cas ou elle soit en 2.0, merci pour cet énorme travail.

    Une remarque à propos des fichiers .wav, les nombres supérieurs à 100 sont bizarres, tant en “eu” qu’en “fr”, normal ou pas ?

    tistis

  15. @Tistis : Merci 😉 Pour les fichiers .wav, qu’est ce qui te parait bizarre ? le fait que 101 dise “200”, le 102, “300”, etc ? Si c’est cela c’est normal, en fait les numéros (nom du fichier) correspondent à un “id” (sous le forme d’un nombre) qui est ensuite utilisé dans le code de la radio pour la faire parler. Ils ne correspondent pas à ce qu’ils “disent” (même si c’est le cas pour les 100 premiers 😛 ).

  16. Salut!

    J’ai bien suivi le tuto de mise a jour, mais si j’allume la radio avec les 2 trim vers l’interieur, ca m’affiche “taranis bootloader 2.1.6 est ce normal? je ne devrais pas etre en bootloader 2.1.7?

    merci

  17. Je repond moi meme a mon precedent “commentaire”.

    A vouloir faire trop vite, j’ai zappe l’etape de changement de driver par zadig donc… ca n’avait pas marche!

    Merci pour ce superbe site.

  18. Merci Olivier, excellent tuto et parfaitement détaillé.
    Petite question, j’ai transféré mon nouveau Firmware aujourd’hui le 2.1.8, il me reste à apporter les modifs dans la carte Micro SD. J’ai sauvegardé des modèles de la 2.0, création d’un fichier .eepe, est il possible de l’importer par la suite, si j’utilise ton zip pour la micro SD je vais écraser les modèles présent sur la carte.
    Merci d’avance et encore bravo

  19. Apres plusieurs lectures, c”est ici que j’ai trouvé les réponses à mes questions: les archives au cas où ça se passe mal . ….
    Excellent donc sans réserve.
    Chacun ses manies et donc qq remarques personnelles:
    – quand plusieurs solutions son proposées, j’ai utilisé la plus simple à maitriser
    – pour les dossier BMP il me semble plus simple de dire: copier votre dossier
    – pour les dossier SOUND: copier votre dossier puis dans SOUND/systeme placer les fichiers ci-joint.
    et ça fonctionne; un grand merci

  20. Bonjour,
    j’ai mis à jour ma radio Taranis x9d plus version EU mise a jour (2.0.20), je suis sur le point de la mettre en version EULBT grace à votre tuto pour pouvoir utiliser mon XSR acheté en France donc EULBT et flasher par la radio mon X8R de 2015 versions EU. Ma question porte sur la migration de ma radio en 2.1.9 y a-t-il un interet et un tuto sur le sujet.
    Je tient a vous dire merci pour ce super tuto.

  21. super tuto! migration effectué!
    la nouvelle telemetry ne me donne plus le paramètre “consp” ( consolation en mAh) que j’utilise pour le virtual current sensor.
    mais je devrai pouvoir retrouver l’équivalent via le “fuel” ( en % de batterie du coup)

  22. Question hyper naïve (aux spécialistes) : pourquoi la Taranis est-elle (semble-t-elle) la radio pour pilotage de drone racer idéale ? (a part que toute le monde en a une) Je suis en Spektrum et je me demande ce qui justifierait un budget dépense pour une nlle Radio… à moins …

  23. juste pour info le pack son contient un dossier “FR” et un dossier “EN”.
    Attention la version EN ne fonctionne pas ( les valeurs de voltage ne s’énonçait pas correctement) .
    Si vous êtes en EN il faut télécharger les sons sur le site openTX

  24. Question naive d’un débutant ex racer:

    1:: je souhaite acheter une taranis X9D + module ORX pour faire voler un mini vortex 150.
    mais que pensez vous de la nouvelle petite Q7X ?? est ce suffisant ?

    2:: faut il acheter une version EU ou US ou INT ?? même question pur les récepteurs …

    MERCI

LAISSER UN COMMENTAIRE

Please enter your comment!
Please enter your name here