Happymodel Moblite7, le test

31
3344

Ce Tinywhoop cultive ses différences par rapport aux modèles concurrents. Le maître-mot ? Spartiate. Le résultat ? Son autonomie est record pour un appareil de cette taille. Le Moblite7 (ainsi que le Moblite6) sont inspirés des essais de Nate Paye (alias Mr Shutterbug), qui s’est efforcé de réduire au maximum le poids d’un nano racer 1S pour optimiser sonautonomie (voir ici). Est-ce que sa méthode fonctionne ? Que vaut le Moblite7 ? Réponse dans cette chronique.

La vidéo

Tour du propriétaire

Le Moblite7 est livré dans une pochette de transport. Il repose sur une structure en plastique souple avec des protections d’hélices. Sa diagonale de moteur à moteur est de 7,5 cm et ses dimensions dont de 9,9 x 9,9 x 1,5 cm. L’épaisseur en tenant compte de la caméra est de 2 cm seulement : L’électronique de bord ne dépasse pour ainsi dire pas de la structure. Les moteurs sont de minuscules modèles brushless EX0802 à 19000KV pour des hélices bipales HQProp de 4 cm de diamètre 40MMX2. Ils fonctionnent en disposition « props out », c’est-à-dire dans le sens inverse de celui par défaut de Betaflight. Les fils des moteurs sont directement soudés sur le contrôleur de vol tout-en-un équipé d’un ESC 4 en 1, le but étant de se passer des quelques grammes qu’imposeraient des connecteurs.

L’électronique ?

Le contrôleur de vol est un DiamondF4 FR basé sur un processeur F4 et flashé avec Betaflight en CrazybeeF4FR. Ce contrôleur de vol inclut un ESC 4 en 1 de 5A BLheli_S destiné à des batteries 1S. Ce n’est pas tout : il offre aussi un récepteur radio SPI 2,4 GHz compatible FrSky D8 et D16 (Non-EU), avec une antenne assez longue (10 cm) fixée sur un connecteur u.FL. Enfin, il intègre un émetteur vidéo 5,8 GHz analogique compatible avec 40 canaux, capable d’émettre à 25 mW et 200 mW, avec le support de SmartAudio et une petite antenne cuivre assez rigide. Il inclut aussi plusieurs LED dont deux sont pilotables via Betaflight. Il n’y a pas de buzzer à bord.

La partie vidéo

La dotation est complétée par une caméra petit format, une Nano3 de RunCam 800TVL qui mesure 1,4 cm de côté. Sa fixation est originale : c’est une languette en TPU fine qui part de l’arrière de l’appareil et s’enroule à l’avant autour de la caméra, avec un morceau de mousse. La solution semble très « bricolée », mais elle a l’avantage d’être de conception simplissime. La caméra a peu d’angle par défaut. Mais il suffit de percer des trous supplémentaires sur la languette à l’arrière de l’appareil pour la tirer un peu plus. Par effet mécanique, la caméra s’incline plus : parfait pour les pilotes qui désirent accélérer et prendre de l’angle…

L’alimentation

Le Moblite7 est prévu pour accueillir des batteries 1S avec un connecteur PST PH2.0. Un panier intégré sous la structure permet de glisser la batterie. Happymodel en fournit deux exemplaires, des LiHV 1S 650 mAh 60C. Ce sont des LiHV, elles peuvent par conséquent être chargées jusqu’à 4,35 V. Un petit chargeur USB pour une batterie est fourni dans la pochette, il permet une charge complète en 50 minutes environ. J’ai réalisé mes essais avec ces deux batteries, mais aussi avec des LiHV 550 mAh de UrUAV et des 450 mAh de Emax. Le poids sans la batterie est de 19,7 grammes. Comptez 15,4 grammes supplémentaires avec la LiHV 650 mAh, pour un poids au décollage de 35,1 grammes. C’est l’un des nano racers les plus légers que j’ai eu en mains (le tenant du titre du plus light étant le Tiny Whoop Nano de TBS).

Les réglages

Le Moblite7 est proposé avec le firmware Betaflight dans sa version 3.5.7. Elle n’est pas très récente, même si elle est pleinement fonctionnelle. La connexion avec un ordinateur pour utiliser Betaflight Configurator passe par un connecteur microUSB situé sous l’appareil. Il faut pousser un peu l’un des montant de la cage batterie pour le branchement – ce n’est pas un souci puisque la structure est flexible. La plupart des réglages sont déjà effectués d’usine, y compris les PID, les ports et les UART (dont SmartAudio pour l’émetteur vidéo), l’angle d’armement, l’OSD. Ne reste plus qu’à appairer la radiocommande et associer les interrupteurs aux modes de vol, à l’armement, à la fonction Flip Over After Crash, etc. Pour lancer l’appairage côté Moblite7, il suffit de passer dans le CLI et taper la commande « frsky_bind ». Pratique. J’ai appairé l’appareil avec une Radiomaster TX12 en D8, donc avec le réglage « FRSKY_D » de l’onglet Configuration.

En intérieur ?

Les premiers coups de gaz montrent que le Moblite7 est plutôt costaud par rapport à son poids plume. Il monte vite, et les commandes sont très réactives. Mais pas trop : les réglages des PID et des rates sont satisfaisants, à tel point que je n’y ai pas touché. En intérieur, l’appareil sait se tenir en vol stationnaire (en Angle stabilisé et en Acro sans stabilisation), et permet de voler de manière tranquille pour aller explorer les pièces d’un appartement. Il est aussi capable d’accélérer sérieusement pour le lancer dans des vols énervés entre les meubles et les occupants humains et animaux. La bonne nouvelle ? Le poids plume du Moblite7 le rend inoffensif, même lancé à pleine vitesse. Il n’y a pas de vibrations parasites, l’image est correcte (toutes proportions gardées puisqu’il s’agit d’un retour vidéo analogique).

>>>> LA SUITE DE CETTE CHRONIQUE SE TROUVE ICI <<<<

31 COMMENTAIRES

  1. Bonjour,

    Pour ma part, j’attends le miens depuis janvier…
    Vendredi ils m’ont annoncé un retard de 20j supp…

  2. Merci Fred pour le test.

    Tu as constaté des différences (comportement, autonomie, …) après le passage en BF 4.2?
    Sur ces tiny je me demande toujours si le mieux n’est pas l’ennemi du bien côté version de BF (souvent même des modèles récents sont vendus avec de vieilles versions de BF)
    Merci!

  3. Bonjour Fred,
    Merci pour ce test. Je viens de recevoir le mien.

    C est curieux, le VTX m affiche 25, 200, 500 ou 800 mw ? Comment l expliquer ?

    Je n ai pas pu tester la portée vidéo en extérieur pour l instant… Mais l autonomie est énorme.

  4. Merci pour le test très rapidement ndtructif et toujours aussi détaillé et précis 👍👍. J’ai commandé le mien il y a 10 jours, en complément du Mobula 6 25000kv.
    Hâte de le recevoir pour varier les plaisirs.

  5. Bonjour,
    Je débute et ce modèle pourrait m’intéresser mais j’ai un doute concernant la compatibilité avec ma RC.
    J’ai une Taranis X-Lite Pro en EU LBT. Ce quad est NON-EU.
    Dois-je passer mon chemin ou y a-t-il quelque chose à remplacer ou flasher?
    Merci pour votre aide.
    Philippe

  6. @Philippe H. : Il est théoriquement possible de reflasher la radio, mais je ne sais pas si FrSky a mis les fichiers à dispo. L’alternative, c’est d’utiliser un module externe de type IRangeX IRX4 LITE. Il te permet de continuer à utiliser les éventuels appareils EU-LBT et d’appairer ceux en Non-EU, D8 et D16. Mais comme je n’ai pas de X-Lite Pro, je ne suis pas 100 % certain…

  7. Bonjour ! Merci infiniment pour tout ces test et tuto, quand on se lance doucement dans le FPV, il y a tellement de choses a ingérer pour le débutant que je suis… Rien que le langage demande un certain temps !
    Bref, j’ai également du mal avec les protocoles EU-LTB également. J’ai une Betafpv LiteControler 2 SE pour m’entrainer sur simu, et je souhaite enfin faire l’acquisition d’un premier Tiny-whoop pour apprendre (j’ai choisi des EV800DM car je porte des lunettes) in-door, et rapidement un peu en extérieur sans vent. Que me conseillez vous svp pour une compatibilité matériel sans flashage ? J’avais craqué sur ce Moblite7, sa douceur de vol et sa grande autonomie, mais je viens de lire votre réponse et sa non compatibilité… Du coup, un Mobula 6 ou 7 ?
    Merci d’avance pour votre aide, sincèrement.
    Jonathan

  8. @ Jonathan MDS : L’avantage de Betalite 2, c’est qu’elle est compatible avec le D16 EU-LBT et Non-EU, et le D8. Donc pas de souci de compatibilité du Moblite7 avec cette radio (à la différence d’une Taranis X-Lite Pro).

  9. Bonjour @Fred,
    Merci pour ta réponse.
    Je me suis lancé : j’ai acheté le Moblite 7 et un module XJT Lite pour ma Taranis X-Lite Pro.
    J’ai mis à jour le firmware du Moblite, j’ai configuré Betaflight/Récepteur en FRSKY_D pour être compatible avec le mode D8.
    Sur la Taranis, je mets HF externe en XJT Lite D8 et je tente de binder.
    Cela ne fonctionne pas.
    Je m’arrache les cheveux. C’est mon premier bind, je débute.
    Si tu as une piste, je suis preneur :/
    Philippe

  10. @ Philippe H.: Hmm, pas facile de trouver la raison 🙁
    La commande frsky_bind ne te donne pas d’erreur ?
    Après avoir initié la commande frsky_bind, quand tu lances le bind dans le menu de la radio, est-ce que les LED du récepteur changent ou pas du tout ?

  11. @Fred Non la commande frsky_bind reste en attente, à l’écoute. Les LED du récepteur ne changent pas lorsque je lance le Bind.
    J’ai un peu tout essayé : mise à jour des firmwares du module externe, du module interne (sur la V1 et la V2), mise à jour OpenTX via le site officiel et via Companion.
    Côté Moblite7, j’ai mis à jour le firmware en CRAZYBEEF4FR dernière version stable.
    L’émetteur et le récepteur ne s’entendent pas.

  12. @Philippe H. : Ok. Même si le bind fonctionne, la fonction bind dans le cli (bind_rx si tu es en 4.2.8) ne te rend pas la main, tu ne verras si ça fonctionne que par un changement dans la LED.
    Tu es bien en Spi Rx Support ?
    Pas d’UART activé sauf l’USB VCP et le VTX en Peripheral sur l’UART 2 ?

  13. @Fred : Merci encore pour ton aide…
    OK pour le bind, je ne le savais pas. Quoiqu’il en soit, pas de changement. Avant de lancer la commande, j’ai une alternance on/off des LED rouge et jaune.
    Après avoir lancé la commande bind, la LED rouge reste allumée.
    Pendant les tentatives de binding, la LED reste fixe et la RC bip. Si cela fonctionnait, la RC stopperait les bips il me semble.
    Je suis bien en Spi RX.
    Sur les ports, seul l’USB VPC est activé (en 115200). Le reste est vierge.
    Je n’ai pas encore configuré le VTX. Il faudra choisir TBS Smartaudio ou RC Tramp? Sur cette ligne UART2, il n’y aura rien d’autre à activer?

  14. @Philippe H. : Les LED du récepteur sont rouge et vert (faible). Ils sont sur la droite du connecteur USB quand tu regardes le drone par le dessous. Juste à côté, sur le bord, tu as l’une des LED pilotables avec Betaflight, beaucoup plus lumineuse…
    Normalement, quand tu branches l’USB, tu as la verte qui clignote très rapidement, puis plus doucement. Juste à côté tu as la rouge qui est sans doute fixe. Quand tu lances la commande bind, il ne se passe rien. Quand tu bindes du côté radio, la LED route clignote quand le bind est fait. Quand tu débranches puis rebranches tout, les LED ne disent rien de plus (led vert qui clignote faiblement, led rouge fixe). Mais tu as le retour des joysticks dans Betaflight.
    La RC ne stoppe pas les bips quand le bind est fait, c’est à toi d’arrêter le truc.
    Tu peux aussi essayer d’initier le bind avec le bouton, sans brancher l’usb : tu branches la lipo, les led vert et rogue clignotent. Ensuite tu appuies sur le bouton bind, c’est celui qui est le plus éloigné du connecteur usb, à côté du composant carré. Quand il est entré en bind, il passe au rouge fixe.
    Sur la ligne UART2, tu as juste à activer TBS Smartaudio… (mais ça n’aura pas d’impact sur le bind)

  15. @Fred : Je branche et regarde sous le même angle que toi.
    La verte clignote vite puis normalement. sa voisine la rouge clignote également (la plus lumineuse pour moi). De l’autre côté de l’USB, une LED rouge est fixe.
    Je lance bind_rx, seul changement, la LED rouge qui clignotait (la voisine de la verte) est désormais fixe.
    Je lance le bind sur la RC, rien ne change.
    Je débranche et rebranche. Dans Betaflight, je vais sur Récepteur, je bouge les joystick, rien ne bouge sur les lignes AERT. Sur cet écran, je n’ai touché à aucun paramètre.

    Lors du bind, la LED rouge n’étant pas passé du statut fixe au clignotement, on peut en déduire que le bind ne se fait pas, si je comprends bien.

    J’ai réessayé avec Lipo et bouton, c’est pareil.

    J’essaie de comprendre pourquoi l’émetteur et le récepteur ne se voient pas. Le récepteur est en D8 Non-Eu. Dans Betaflight, j’ai configuré FRSKY_D, et je suis bien en SPI RX.
    Sur l’émetteur, j’ai ajouté un module externe XJT lite pour le rendre compatible. Je bind bien sur le module externe, en choisissant le mode XJT lite en D8.

    J’ai testé différentes combinaisons de firmwares. Désormais, je suis sur les dernières versions partout.

  16. @ Philippe H. : Ok, je n’ai pas de Xlite ni de XJT lite pour essayer 🙁
    Tente quand même, après avoir lancé le bind des deux côtés, de taper “set frsky_x_rx_num” dans le CLI puis “save”…

  17. @Fred :
    Après avoir lancé la commande, la LED verte est devenue fixe.
    Dans le CLI, il n’y a rien eu après cette commande. Pour le “save”, j’ai cliqué sur enregistrer sous, il a juste enregistré le contenu du CLI :

    # bind_rx
    Binding…

    # set frsky_x_rx_num

    Par “save” c’est bien cela que tu voulais dire?

  18. J’ai également écrit “save” dans le CLI après avoir tapé “set frsky_x_rx_num”.
    Aucune action apparente.
    La commande save ne s’est pas inscrite dans le CLI.
    Les LED n’ont pas évoluées.

    J’ai débranché, rebranché et testé l’action des joysticks dans Récepteur sur Betaflight, rien ne bouge.

  19. @Fred : je viens d’essayer avec la Taranis Q X7 d’un copain, équipée d’un module XJT.
    J’ai appliqué la même méthode que lors de mes tests, et le bind a marché du premier coup!
    Le problème semble donc venir de mon module externe.
    Merci pour ton aide.

  20. @Philippe H. : Oh, désolé, j’ai loupé tes derniers messages 🙁
    Oui, c’était bien save à taper dans le cli pour valider (pas enregistrer sous qui ne fait que stocker l’historique du CLI). Normalement ça te déconnecte du CLI. Mais c’est ce que tu as du faire.
    Je n’ai plus d’idée… 🙁

  21. @Fred : J’ai réussi à binder avec ma RC.
    Je suis repassé sur ISRM 1.1.3 EU. Je souhaitais revenir sur la version 1.x du firmware du module externe XJT Lite mais je n’ai pas réussi à le trouver. Je suis donc en 2.1.0 FCC.
    J’ai enfin réussi à trouver le script LUA qui permet de passer le module interne en FCC. Je l’ai donc passé en FCC.
    Le bind ne fonctionnait toujours pas.
    Je suis tombé sur un forum où d’autres personnes avaient le même problème (https://forum.wearefpv.fr/topic/10300-xjt-lite/page/4/#comments), et le dernier commentaire présente la piste que tu m’avais donnée :
    >set frsky_x_rx_num
    >bind_rx
    >lancer le bind sur la radio, attendre 30 seconde, 1 minute…puis taper save dans le CLI.
    >La led de bind ne se lock pas avec cette procédure mais ça a fonctionné

    Et en effet, l’action des boutons était visible dans Betaflight.

    Je ne sais pas si toutes les étapes préalables étaient toutes nécessaires, je n’avais pas enchainé exactement la séquence comme décrite ici.
    J’ai testé en repassant le module interne en LBT, le bind est maintenu, j’ai aussi désactivé le module interne, le bind est maintenu également.

    Côté récepteur, la mise à jour avait réinitialisé tous les paramètres. J’ai essayé de les reporter depuis une vidéo (https://youtu.be/YCwNRqpPIRc) mais il semble que des paramètres identiques sur 2 versions de firmware différentes peuvent avoir des effets différents.
    Ne maitrisant pas encore les paramètres de betaflight, l’idéal pour moi serait de restaurer les paramètre usine. J’ai importé le dump que tu fournis dans l’article mais je ne suis pas sûr de la bonne prise en compte.
    Sais-tu s’il est possible de restaurer les paramètres usine sur un récepteur, ou d’importer une configuration globale “prête à voler”?
    Pour le moment, j’ai assigné les 4 voies de pilotage et le bouton d’armement.
    Lorsque j’arme, les hélices tournent. Si j’actionne un joystick, les moteurs accélèrent un peu et tout se coupe (désarmement je pense).
    Impossible de décoller donc. Je pense que la configuration n’est pas bonne, je vais travailler dessus, mais l’import d’une conf qui fonctionne me faciliterait les choses pour apprendre le rôle de chaque paramètre.

    Aussi, le signal est faible alors que je suis à 1 mètre. La RC m’indique “télémétrie perdue”, “télémétrie retrouvée”.

  22. @ Philippe H. : Ok, ça progresse 🙂 🙂
    Pour le désarmement, il y a pas mal de raisons possibles. Vérifie que les hélices sont bien placées. Vérifie que les moteurs tournent dans ma bonne direction (un par un dans la case motors de Betaflight), c’est du reversed par défaut. Vérifie que les positions des moteurs sont les bonnes (1 2 3 4), au même endroit dans BF. Vérifie que le contrôleur est bien orienté à 180° de yaw dans BF, et le 1er gyro à 90°. Fais un calibrage de l’accéléromètre bien à plat. Après ces vérifs de base, c’est généralement plus compliqué 😎

    Le dump est complet, il doit normalement te remettre la machine en sortie d’usine.

    Pour la télémétrie perdue, c’est normal si ça t’arrive à courte distance, mais ça ne doit plus le faire au-delà de 2 mètres.

  23. @Fred : oui, j’ai avancé, ça devient intéressant.
    Mon problème venaient de la non inversion du sens de rotation des moteurs.
    J’ai voulu vérifier les moteurs dans BetaFlight configurator mais ilpossible de les faire tourner. Lorsque je monte les curseurs, les moteurs ne tournent pas.
    Sur la notice, ils donnent les commandes pour configurer le mapping des moteurs après mise à jour du firmware. Je l’ai fait et ça ne fonctionnait plus.
    J’ai repris ton fichier de configuration que j’ai collé dans le CLI et j’ai fini par save. Et là ça fonctionne. Je n’avais pas fait save lors de mon premier test.
    Très pratique ta configuration pour démarrer, un grand merci.
    J’ai retesté les moteurs sur Betaflight Configurator, c’est pareil, ils ne tournent pas. Pourtant, une fois sur Lipo, ils tournent bien.
    J’ai galéré à retirer les hélices et l’outil fournit ne permet pas de le faire, il se tord. J’ai dû le faire avec 2 fourchettes. Tu aurais une astuces pour les retirer sans rien abimer?
    J’ai pas mal testé ce matin en vol à vue dehors mais il y a pas mal de vent. C’est pas facile 🙂
    Je m’en sors mieux en mode Angle ou Horizon. Le mode par défaut (position non configurée) sur l’interrupteur est accro si je comprends bien. C’est le cas pour sur tous les quads?
    Pour la distance de réception, je n’ai pas encore vu la limite mais j’ai beaucoup d’alertes d’Open Tx (“signal RF faible”).
    Pour le calibrage de l’accéléromètre à plat, c’est pas simple avec la connexion micro-USB sous le quad, il n’est pas à plat. Du coup je le fais en le portant, à l’oeil… Tu aurais une astuce?
    Enfin, je sais qu’avec le retour OSD on a le retour sur la tension de la batterie. Je cherche à l’avoir aussi en vol à vue. J’ai trouvé ça : https://youtu.be/_RjU1TTbB0U. Il y a peut-être mieux?

  24. @Philippe H. : Ahhhh 🙂
    Pour les moteurs, il faut brancher sur BF, alimenter avec une Lipo et bien cocher la case pour que les moteurs démarrent dans l’onglet de test (c’est une sécurité).
    Pour les hélices, j’utilise une pince à épiler en faisant levier, mais par le dessous. Ca reste parfois galère à retirer… surtout quand les pales ont sauté !
    Tu peux configurer le mode Angle et le mode Horizon (stabilisés). Le mode Acro est le mode “aucun des deux” (pas de stab). N’oublie pas de mettre l’Airmode pour conserver toujours un filet de gaz, sinon les moteurs sont totalement coupés à gaz à 0, et tu perds le contrôle.
    Essaie de passer au plus vite en immersion et de t’habituer le moins possible à voler en stabilisé, sinon tu vas avoir beaucoup plus de mal à voler en Acro, et pourtant c’est dans ce mode que tu profites vraiment du pilotage, même sans vouloir faire des figures, juste pour voler tranquillement. Il est beaucoup plus facile de voler en Acro en immersion qu’à vue…
    Pour le calibrage, je pose le nano sur un mug, ça permet en général d’avoir l’assise tout en ayant le câble USB branché.
    Pour le retour télémétrie sur la QX7, sorry, je n’ai pas tenté 🙁 (je ne vole quasiment plus en vue directe).

  25. @Fred : merci pour tous ces bons conseils. J’apprends vite avec toi. Il y a tellement de choses à savoir pour démarrer.
    Pour les moteurs sur BF, en effet je n’avais pas branché la lipo, je n’avais pas pensé que la puissance délivrée par le PC n’était pas suffisante.
    Super l’astuce du mug, c’est bien noté.
    OK pour vite passer en immersion, je comprends. Je crois que j’ai déjà prise les mauvaises habitudes avec le Furibee F36 en vol à vue :/
    C’est rassurant si l’acro est plus facile en immersion, je vais vite tester.
    A bientôt

LAISSER UN COMMENTAIRE

Please enter your comment!
Please enter your name here

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.