Butter : l’outil pour revenir à un ancien firmware sur DJI FPV Air Unit, Goggles V1, Goggles V2 et Vista

8
1152

Si vous avez mis à jour votre matériel DJI Digital FPV System, c’est-à-dire le boitier DJI FPV Air Unit et ses déclinaisons chez Caddx (Air Unit Lite et Vista) et RunCam (Link), le casque Google V1 ou le Googles V2, vous n’avez peut-être plus accès à des compatibilités entre certains produits, à des bidouilles, au hack wtfos, etc. Et plus moyen de downgrader vers un firmware plus ancien. La bonne nouvelle, c’est que l’équipe de fpv-wtf, à qui l’on doit justement wtfos, propose un outil pour remédier au problème.

Cet outil s’appelle Butter

Il est proposé en open source, gratuitement, sur son Github. Il n’est disponible que pour PC Windows et Linux. La procédure s’appuie sur l’exécutable Butter à lancer via une ligne de commandes. Des packages prêts à l’emploi sont disponibles pour le FPV Air Unit, le Air Unit Lite (Vista et Link), le casque Googles V1 et le casque Goggles V2. 

Et ça fonctionne ?

Sur mon poste de test Windows, mes FPV Air Unit et Vista n’ont pas été reconnus par Butter. Je suppose qu’il s’agit d’un souci de driver. Si vous obtenez des résultats plus probants que moi, tenez-nous au courant !

Article précédentDJI Mavic 3 : les waypoints vont-ils permettre des missions de type photogrammétrie ?
Article suivantJobs : CF2i-Formation recherche un formateur drone en freelance et un formateur référent drone

8 COMMENTAIRES

  1. Testé le soir meme après ca sortir avec un gars de WAF et impec ca marche tu tonnerre merci WTFOS pour ce superbe cadeau de noel !

    Ph3nWh1ck

  2. If flashing your device with butter never gets past “[ ] Waiting for DJI Recovery device to enumerate..” here’s what you can do:
    – Make sure you’ve installed the proper drivers using driver_installer.exe
    – Try another USB cable
    – Try another USB port (2.0 if you have one)
    – Try restarting your PC
    – Try another PC

    Usually some combination of cables and USB ports will work. If not, find a friend with a PC willing to help out. Raspberry PIs are also known to work.

    Si le clignotement de votre appareil avec butter ne dépasse jamais “[ ] En attente de l’énumération de l’appareil de récupération DJI..” voici ce que vous pouvez faire :
    – Assurez-vous d’avoir installé les pilotes appropriés à l’aide de driver_installer.exe
    – Essayez un autre câble USB
    – Essayez un autre port USB (2.0 si vous en avez un)
    – Essayez de redémarrer votre PC
    – Essayez un autre PC

    Habituellement, une combinaison de câbles et de ports USB fonctionnera. Sinon, trouvez un ami avec un PC prêt à vous aider. Les Raspberry PI sont également connus pour fonctionner.

    Jonas de wtfos

  3. @Ph3nWh1ck je dois surement mal m’y prendre, j’ai bien réussi à installer les drivers, et à flasher les goggles V2 qui sont en 01.03.0000 mais après redémarrage elles sont encore sur le même firmware, comment faite vous pour les downgrade ?

  4. Bonjour, j’ai suivi la procédure dans les info du masque je suis bien en v01.00.0606 mais quand je vais sur le site pour rooter il me mais la version v01.00.0607!!!
    Il y a t’il une manip supplémentaire?

  5. @ Ph3nWh1ck : Bonjour, étant actuellement en version 1.06.00.00 sur mon google V2, j’aimerais installer le hack FCC, mais celui de b3yond n’est plus compatible avec les version supérieur à 1.02.
    Si j’ai bien compris en suivant la procédure Butter sur ce Github je pourrais downgrade mon masque et installer le hack Fcc par la suite ?

LAISSER UN COMMENTAIRE

Please enter your comment!
Please enter your name here

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.